Mercedes A-Class Forum banner

21 - 38 of 38 Posts

·
Registered
Joined
·
427 Posts
What annoys me these bloody MB dealers know what the problem is yet will persist in telling customers it’s their fault for using cheap (in other words crap) washer fluid.
One member in this forum was quoted (in London) £1200 to clean through system & replace blocked jets &/or tubes....bastards
 

·
Registered
Joined
·
126 Posts
Great fix, cutting the edge of the gromet out! Thanks for the tip. I always use "cheap fluid with tap whater", nevertheless, mine didn´t cloged yet!
If I ever remove that wheel liner for any reason, I'll apply the preventive fix ;-)
 

·
Registered
Joined
·
246 Posts
Am I missing something here? Will removing the filter not result in the jets blocking. Surely the filter is there for a purpose !
 

·
Registered
Joined
·
27 Posts
Am I missing something here? Will removing the filter not result in the jets blocking. Surely the filter is there for a purpose !
nope, pointless.
Unless you want to remove your wheel and inner arch every 12 months to clean it. Cut the filter end off it and there’s no qualms.
 

·
Registered
Joined
·
110 Posts
What annoys me these bloody MB dealers know what the problem is yet will persist in telling customers it’s their fault for using cheap (in other words crap) washer fluid.
One member in this forum was quoted (in London) £1200 to clean through system & replace blocked jets &/or tubes....bastards
always use the washer fluid from MB dealer, don't use others, i had same experience for my vw car, never use other washer fluid
 

·
Registered
Joined
·
126 Posts
Why using MB "genuine" washer fluid?! Is it milked from unicorns by angels! ? Probably that's why so many have issues with cloged filters. I use a cheap old PT brand (Redex) mixed with tap whater. No problems in 25 years.
 

·
Registered
Joined
·
1 Posts
This worked for me. Washers were only squirting on the button press. Access to the rubber grommet not quite as simple as described, I needed to take a third push pin out. And then I was unable to unclip the pump from the tank, but by disconnecting it and pushing it up out the way I could get the grommet out. Cleaned that, flushed some clean water through the tank and it fired up straight away on reassembly. Thank you.
 
21 - 38 of 38 Posts
Top