Mercedes A-Class Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi everyone

Looking for some advice please. Ive had my A200 just over a year and i keep randomly getting this problem.

The car will just loose power like its gone into limp mode and it takes ages to build up speed and theres no kick to to it. Im sure the turbo stops working whenever this issue happens. It will eventually change gear at high revs over 3000 and then take ages to build up speed again. If im in sports mode it will automatically change to eco mode and wont switch to turbo or manual.

Whenever this happens im never near the mechanics so that i can show them the problem. Ive connected an OBD reader when it does happen to see if any sensors or fault codes comes up but nothing comes up and it shows all the sensors are working fine.

If i switch the car off for a couple of minutes and then turn it back on it works fine but then sometimes it will happen again a bit later as im driving along.

Any advice on what it could be so i can tell the mechanic to check X sensor or X part because im getting really fed up with how dangerous it is.

Thank you for any help or info you can provide.
 

·
Registered
Joined
·
35 Posts
Guys what ever happened in car Fault code DTC reason will be written in faulty ECUs

Diagnostic is alpha omega to start with
 

·
Registered
Joined
·
10 Posts
Guys what ever happened in car Fault code DTC reason will be written in faulty ECUs

Diagnostic is alpha omega to start with
I’ve had it on a diagnostics and it came up with accelerator pedal and throttle body. I’ve had the pedal replaced with a new one and it’s come on again a few days later. So I’m guessing it’s the throttle body?
 

·
Registered
Joined
·
10 Posts
Is your car diesel or petrol?

What DTC you had?
Diesal, I didn’t manage to get it off the bloke who did it, but it’s strange how both those faults showed up and now I’m having the same problem, I’m going back Monday I’m hoping I can get it sorted, I’ve got a feeling it’s the throttle body as it seems to act up in higher gears such as 6 and 7(semi auto) sometimes it’ll just fly up to 4000 revs and delays in acceleration
 

·
Registered
Joined
·
35 Posts
In diesel car is just air flap not throttle body ( people call them throttle but throttle body but T/B is only on petrol cars ;) )
this air flap working just in 2 position open or close and helping stop car when turn off engine flap shut close air and engine stall better. When engine rune is constantly fully open.

Sometimes those flap have worn out gearing - let try swap for new cost nothing possibly will help
 

·
Registered
Joined
·
10 Posts
In diesel car is just air flap not throttle body ( people call them throttle but throttle body but T/B is only on petrol cars ;) )
this air flap working just in 2 position open or close and helping stop car when turn off engine flap shut close air and engine stall better. When engine rune is constantly fully open.

Sometimes those flap have worn out gearing - let try swap for new cost nothing possibly will help
I’m taking it to the mechanic Monday, the Diagnostic code reader may help find out what it is cause at the minute the light goes on and off, it just doesn’t make sense then comes on after 20 minutes of driving!?!
 
1 - 8 of 8 Posts
Top