Mercedes A-Class Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
Earlier I had a message when driving. I think it said 4matic unavailable
I removed it from the screen as was not concentrating as my son was whinging in back
Anyone no what it means
 

·
Registered
Joined
·
15 Posts
Earlier I had a message when driving. I think it said 4matic unavailable
I removed it from the screen as was not concentrating as my son was whinging in back
Anyone no what it means
Typically after reading this on the forum last night I’ve just been out in my a35 and the message: 4matic inoperative has come up on the screen in my car too.....
 

·
Registered
Joined
·
69 Posts
Discussion Starter #3
Typically after reading this on the forum last night I’ve just been out in my a35 and the message: 4matic inoperative has come up on the screen in my car too.....
Do u have an idea as to what it means?
I got no engine lights on or Nufin so I dunno if it serious or not
 

·
Registered
Joined
·
15 Posts
No, just had rac out and they can’t connect with the 4matic ecu. Having a look online it could be a software update. My cars only a month old from new. So not best impressed. But mine is the same as yours: a message on the dash when you first start the car, but no warning lights etc otherwise on the dash....
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
No, just had rac out and they can’t connect with the 4matic ecu. Having a look online it could be a software update. My cars only a month old from new. So not best impressed. But mine is the same as yours: a message on the dash when you first start the car, but no warning lights etc otherwise on the dash....
I just had my car Remapped a week ago, so thought it was that but if yours is basically new it can’t be, I seen on other sites saying it’s a software issue,some say tyres, changed then last week too to Michelin,let me no the outcome to it, and I’ll do same
 

·
Registered
Joined
·
15 Posts
No problem, I will let you know. Been out to the car this morning and had no warning come on the dash. Still going to book it into Mercedes in a little while.
 

·
Registered
Joined
·
44 Posts
Totally different (but similar in a way): I had a couple of starts that brought up the Engine Warning light on the dash. Pressed the Merc 'me' button - they told me clearly; don't worry unless is stays on long term. Over the next couple of days it cleared, never came back up and not thought about it since. I do wonder if sensors get a bit sensitive with changing temp? Not sure if it could be the same thing with the 4matic. Sorry I can't help, but Merc seemed less than bothered about the engine warning light..!
 

·
Super Moderator
Joined
·
3,527 Posts
CEL's have various criteria for clearing.

eg:

If it's emissions related, and the fault hasn't cleared, the light will stay on permanently until the fault is fixed, and has to be manually cleared.

If it's non emissions related, and the fault is a one-off, the CEL will clear after n ignition cycles, but the fault will have been logged in the ECU.
 

·
Registered
Joined
·
15 Posts
Thank you for all the above replies. The car is booked in Monday at my local Mercedes dealer. Light hasn’t been on since though which is good news 👍
 

·
Registered
Joined
·
20 Posts
Totally different (but similar in a way): I had a couple of starts that brought up the Engine Warning light on the dash. Pressed the Merc 'me' button - they told me clearly; don't worry unless is stays on long term. Over the next couple of days it cleared, never came back up and not thought about it since. I do wonder if sensors get a bit sensitive with changing temp? Not sure if it could be the same thing with the 4matic. Sorry I can't help, but Merc seemed less than bothered about the engine warning light..!
My A35 has fuel pressure faults, dealer has replaced the sensor, twice, last time I got the car back the engine management light was on within a mile of the dealership so I turned around and gave them the car straight back, that was 11 days ago and I haven’t heard anything back from them yet, so it’s looking like the car has a major problem somewhere, the car was new in October 2019 and hasn’t done 10k miles yet and I think the dealer has had it for at least 3 months in my ownership, so far it’s the worst car I’ve ever had.
 
1 - 10 of 10 Posts
Top