Mercedes A-Class Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
731 Posts
I hope this wasn't a wind up, as I can't find those options in the menus.
No wind up

Dont start the engine but press the start button twice so the ignition is on, Select Home menu > Info > Engine, and you will see the battery voltage bottom left
 

·
Registered
Joined
·
82 Posts
Discussion Starter #5
My cold battery charge level is 12.1 volts, which seems a little low to me and the normal reading should be above 12.6 volts, unless its different with these vehicles. Once the engine is started however, it stays around 14.6 volts, which is ideal. I wonder if this low voltage is what's causing my front right window bag fault to appear. I had it diagnosed and no airbag fault is actually live on the ecu. Just the stored fault, which after a reset did not appear until driving a few miles, stopping the car and it again reappeared.
 

·
Registered
Joined
·
731 Posts
Mines 11.8v at the moment but its been sitting for a couple of weeks. Still this seems really low to me I get the view that these AGM batteries work differently to conventional wet cell, having said that the float voltage should be higher :rolleyes:
 

·
Registered
Joined
·
731 Posts
My cold battery charge level is 12.1 volts, which seems a little low to me and the normal reading should be above 12.6 volts, unless its different with these vehicles. Once the engine is started however, it stays around 14.6 volts, which is ideal. I wonder if this low voltage is what's causing my front right window bag fault to appear. I had it diagnosed and no airbag fault is actually live on the ecu. Just the stored fault, which after a reset did not appear until driving a few miles, stopping the car and it again reappeared.
Have you found the volt meter on the dash?
 

·
Registered
Joined
·
82 Posts
Discussion Starter #8
Have you found the volt meter on the dash?
I tried to find that menu, but it just isn't there. I have no information menu in my tabs. The only 'engine' menu I have is under AMG tab and that doesn't show a battery level. I got the battery level to show on the drivers display.
 

·
Registered
Joined
·
731 Posts
I guess you must have a different menu structure all together. What model and year is your car
 
1 - 10 of 10 Posts
Top