Mercedes A-Class Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Evening all

Just got in the car ready to go home and noticed the main screen above the centre console is not working. I have no radio/nav etc also when trying to access these from the dials screen.

Anyone know of a way to hard reset or am I in need of a trip to the dealers!?

car is a 2019 A250

Thanks
 

·
Registered
Joined
·
27 Posts
The same thing happened to me a couple of weeks ago.I turned ignition off and waited a few minutes,turned engine back on and it came back.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Still the same, no screen :(

Looked through the manual and couldn’t find a fuse diagram. Tempted to disconnect the battery but the large plastic cover over it looks very fragile so a bit worried I’ll break it!
 

·
Registered
Joined
·
845 Posts
I wouldn’t do that. Have you tried locking the door n coming back to it later? It’s not an uncommon fault
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I left it for 15-20 mins when I get home and no change. Will leave it for a few hours and see what happens. The whole multimedia system is not booting rather than just the screen. I’ve no sound, at all and can’t change drive modes etc.
 

·
Registered
Joined
·
27 Posts
I hope a longer wait rectifies it.I also looked at the battery cover which as you say is a bit "delicate".Does anybody know how to remove it safely.for future reference?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
All back to normal this morning. Seems a nights rest did it good :) I’ll keep the thread updated if it happens again
 

·
Registered
Joined
·
43 Posts
It happens to me sometimes but I have realised if I drive for a minute it automatically reboots itself by showing a pink screen and then starts to reboot
 
1 - 9 of 9 Posts
Top