Mercedes A-Class Forum banner
81 - 100 of 138 Posts

·
Registered
Joined
·
135 Posts
I can't get W3W to work on my A35 the guy in the video mentions that you need to have NT5.5MBUX or at least I think that is what he said. How do I check if I have this version?
 

·
Registered
Joined
·
107 Posts
Not 100% on is but try is .
 

·
Registered
Joined
·
135 Posts
Not 100% on is but try is .
Thanks on that basis I have it so I wonder why I get 'I'm sorry I can't help you with that' . I was hoping that W3W would improve the Sat Nav as it is the worst I've had, she still won't accept 'navigate home' even though it's in Favorites.
 

·
Registered
Joined
·
107 Posts
Thanks on that basis I have it so I wonder why I get 'I'm sorry I can't help you with that' . I was hoping that W3W would improve the Sat Nav as it is the worst I've had, she still won't accept 'navigate home' even though it's in Favorites.
have you used it before , working ok and have you had any updates just before it stopped working
if so maybe a download glitch. had a download go wrong . Hi Mercedes wont work .
so went in to Mercedes of Worcester (great people there) got it checked out ,found glitch .
and they reloaded a newer update , they said this update is so large that its done at a Mercedes dealership
so may be you need to pop in to them
 

·
Registered
Joined
·
107 Posts
Try log out and then delete the W3W app from your phone , and then do a reset up might work
 

·
Registered
Joined
·
9 Posts
I tested send to car from Google Maps, and W3W iOS app.

Both worked for me today.
Neither work for me. It says that I am not logged into MMe. although that is open and I am logged in. I have checked my Apple settings and all looks OK. I even delete MMe app and re-installed, but it still says I am not logged in from Google maps & W3W
 

·
Registered
Joined
·
107 Posts
Hi
the only thing I can of , is get in touch with
Mercedes Me
 
  • Like
Reactions: Scotty12

·
Registered
2018 A200 AMG Line
Joined
·
291 Posts
When I try to send a What3Words address from the app to my car via Mercedes Me on my iPhone it always changes the destination to "W3 London". It's the same for every address. And sometimes it states the location couldn't be found. Anyone else having this problem?
 

·
Registered
Joined
·
289 Posts
When I try to send a What3Words address from the app to my car via Mercedes Me on my iPhone it always changes the destination to "W3 London". It's the same for every address. And sometimes it states the location couldn't be found. Anyone else having this problem?
Had the exact same problem. Reverted to sending destination direct from MM app instead which is not as exact.
 
81 - 100 of 138 Posts
Top