Mercedes A-Class Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Morning guys
I have a 2018 W177 A250 petrol and bought Apple CarPlay on Sunday 5th September. I cannot get it to work and i'm usually pretty handy at this kind of stuff. The option is there for Smartphone Integration, which wasn't before but it constantly says please connect a carplay enabled device or something like that. This says this and i'll have my phone plugged in and its playing music through the Media tab.
Absolutely lost by this, I have the Mercedes USB C to female USB adaptor thing and I used an aftermarket and an Apple iPhone lightning connector but getting absolutely nowhere.
Has anyone had any issues like this? Tempted to phone Mercedes but cant imagine they will be much help, next option is take to dealership.
Thanks in advance if anyone can help.
 

·
Registered
Joined
·
1,088 Posts
Are you using the correct port, under the sliding compartment?
Are the cables and connectors data compatible?
I use an apple to usb c to lightning cable
Maybe try a different cable?
 

·
Registered
2018 A200 AMG Line Executive pack
Joined
·
110 Posts
Have you linked the phone to the car through the settings for CarPlay on the phone?
 

·
Registered
Joined
·
2 Posts
Same issue with me. Finally go to a deal to upgrade the MBUX (£250) plus bought the smartphone integration (£200) from Mercedes ME to make it work. It works like a charm. , Luckly it is a once-off expenses, not an annual subscription like the other services.
 
1 - 6 of 6 Posts
Top