Mercedes A-Class Forum banner

61 - 80 of 84 Posts

·
Registered
Joined
·
8 Posts
So has this happened a few times on your car, seeing as you have had 5 software updates!? My car has only done this the once so far. It looks like the exact same problem, but I assume your car hasn't got the 2 x 10" screens?
I have the two 7” screens. The centre entertainment screen started first with crashing and glitching. Had 4 software updates on that and then the dash screen started going black. Had an update on that and then another just before Christmas then it did the circle thing on New Year’s Day.
Dealership are looking at replacing my car because if not it’s getting rejected.
 

·
Registered
Joined
·
5 Posts
Hi,
Nice to have found this page. Have had the main screen failure over 10 times in 12 months. The car has been into the dealership on numerous occasions each time this was mentioned. They’ve always acted dumb, and it’s hard to show them an intermittent fault. they send me away with the software update.
Also now have an intermittent problem of the passenger door not opening from the inside, as if it’s on child lock. Maybe I’m doing something wrong.
 

·
Registered
Joined
·
30 Posts
My screen has failed to boot up on a few occasions. I switch off engine, open the door, close the door, lock the car, and then open it and all is fine. If you stay in the car you should see the screen go completely black as when it fails there is a very slight light in it and this needs to go off to ensure a rebooting of the screen.
 

·
Registered
Joined
·
8 Posts
My screen has failed to boot up on a few occasions. I switch off engine, open the door, close the door, lock the car, and then open it and all is fine. If you stay in the car you should see the screen go completely black as when it fails there is a very slight light in it and this needs to go off to ensure a rebooting of the screen.
I got out of mine twice and locked it, didn’t sort it for me unfortunately. Back working the next day though
 

·
Registered
Joined
·
2 Posts
Hi everyone, we just got our A250 with the dual 10" screens. We have had the driver screen gone off once, and the centre screen gone black when you put it to reverse. All cameras appear to be inoperative. We are planning on escalating this to the general manager of Mercedes in Australia after reading this thread. It seems to be a very common issue and it's dead unsafe to drive a car fearing it's screens going off at any point. I think everyone should do the same in their own regions, so Mercedes may issue a recall. It's disgraceful that you spent over $60K and wishing that you had got a Toyota corolla instead.
 

·
Registered
Joined
·
1 Posts
In the UK and have also had this problem. I was told it was software, update was performed and then display failed again a week later! This time a wiring loom had to be replaced; then I discovered that the SatNav option in the main screen was missing, was supposed to have been sorted during annual service but 'they did not have time'. Returned yesterday to be fixed but now told it has to wait for a software fix from the factory in Germany. Back again in two weeks (possibly!). Wish I had never purchased this car - other faults (1) passenger window one touch has failed twice and when you win dit up it comes back down 2cm - had to be 'reset' again yesterday (2) heating system faulty and heated cabin no matter what temp you set it to - I had to get a temp sensor to place in the car before they would believe me - two visits to sort that! (3) Seat restraint sensor fault. Hate this car.
 

·
Read Only
Joined
·
3 Posts
In the UK and have also had this problem. I was told it was software, update was performed and then display failed again a week later! This time a wiring loom had to be replaced; then I discovered that the SatNav option in the main screen was missing, was supposed to have been sorted during annual service but 'they did not have time'. Returned yesterday to be fixed but now told it has to wait for a software fix from the factory in Germany. Back again in two weeks (possibly!). Wish I had never purchased this car - other faults (1) passenger window one touch has failed twice and when you win dit up it comes back down 2cm - had to be 'reset' again yesterday (2) heating system faulty and heated cabin no matter what temp you set it to - I had to get a temp sensor to place in the car before they would believe me - two visits to sort that! (3) Seat restraint sensor fault. Hate this car.
 

·
Registered
Joined
·
1 Posts
I have an A250 and the screen keeps going blank however it’s not the driver cluster if you will it’s the left hand side screen, normally the system would go blank and restart today it didn’t do that, it went blank and after turning the engine off and getting out and locking the doors and waiting 5 min the screen would still not come back on... I had to get to work and about 15 minutes into the journey the screen came back on really dim then went back to full brightness... just booked in at Mercedes which the woman did acknowledge they’ve had a few in with the same issue... not looking forward to the failed repair attempts if they are still dealing with it the same way!
 

·
Registered
Joined
·
2 Posts
Hi there Nic, I’m from Aus as well Sydney, we have only had our A250 for 4 days and today the drivers side went totally black, I rang the salesman as I had his mobile number, he said he hadn’t heard of it before but to disconnect the negative on the battery for 30 seconds then see how it goes. It seems to be ok at the moment but will ge reporting it to them tomorrow. I hope this isn’t the start of some thing of a common issue as next time it does it I’ll get it towed to the dealership at their cost as I’m not legally allowed to drive it with no speedo. I’ll also start taking notes of when it’s happened and pictures so I have some thing for proof if neeeded . Cheers Steve
hi Steve,

we have since uncovered other issues. Our AC went to full on heating mode when we clearly set up the temperature to 18 degrees the other day. We turned the car on and off a few times. Eventually, it seems to have fixed itself. Have you had any other issues since the last update?

Btw, not to invade your privacy or anything, but did you get yours from Sydney north shore dealership? based on the number of complaints on this site, i can see a potential class action happening sooner or later. Or at least we can gather a few Aussie fellows who are having the same issues with the car and take to their Australian GM and Facebook page. They shouldn't get away from this. We chose Mercedes for its "premium" quality. I think the screen going blank is a major manufacturing issue. Once the car passes its warranty period, we would be looking at really high servicing costs.
 

·
Registered
Joined
·
7 Posts
I have a A180d Sedan V177 purchased new Nov.2019 and today when unlocked the car both of the 10' displays were blank. Got out of it and tried to lock it but it wouldn't respond to the remote. Got inside again, switched the engine on for a whil, then off. Got out of it and locked as it should. The car is kept in a garage in normal temperature conditions. I have driven some kilometres, everything works except the dual 10' screens (climate, radio etc). I have reported the problem to the dealership and booked for a check on Monday. They told is either an update that needs to be done or a display control unit needs to be replaced. Will be back with news next week.

UPDATE 6/16/2020: They told me the screens need to be replaced, waiting to receive and replace them.
UPDATE 6/24/2020: Dealer haven't yet received the new screens part, still waiting...
UPDATE 7/04/2020: Still waiting for them to receive the new 10" screens. I wondered why it is taking too long for a part in the EU to arrive with such delay...
UPDATE 7/13/2020: The screens part arrived finally, the dealer's service have replaced the defect screens and everything is working as expected. Hope this was my first and last trouble.
 

·
Registered
Joined
·
49 Posts
There's lots on here about this issue. New CLA with MBUX, had the black screen a few times, dealer couldn't fix with updates so fitted new screen, drivers, all fine ever since.
 

·
Registered
Joined
·
1 Posts
My 2019 A220 is now doing this. The screen with the speedometer is black but the other one is working fine. Another thing I noticed was when I use my turn signals I don’t get the clicking noise. I was hoping I could let it sit and then it would come back on but no luck. Taking it to the dealership in a few days to get it looked at.
 

·
Registered
Joined
·
2 Posts
Hi guys I'm from the UK and my new 2019 A220 AMG Line Premium Plus is having the same issue. Screens went black after a shopping trip got back into the car to go home and the electronic dashboard wouldn't turn on. Called RAC who did a diagnostics test on the car and the technician said the results from his laptop are saying the computer was not able to read the car and its a first because this only happens for cars that are not driveable and cars that are battery dead! Mine was working fine. He tried to do a battery reset still no luck.

Anyways I have called the dealership for a diagnostics appointment hopefully they can fix the issue but reading your experiences doesn't seem like it's a quick fix.

Update today it decided to turn on??? I'm so baffed the last two weeks it wasn't working and today it decided to work?? Really strange. Anyways I'm still taking it into dealership as I feel it may happen again.
 

·
Registered
Joined
·
82 Posts
This is quite a common fault on the dashboards and a number of forum members have taken their cars to the dealerships for diagnostic and repair, with some returning with the fault not rectified. I've had it a few times, and to be honest, I just live with it as I can't be bothered to be without the car, if I were to let it live at dealer on and off!
 

·
Registered
Joined
·
7 Posts
Hi guys I'm from the UK and my new 2019 A220 AMG Line Premium Plus is having the same issue. Screens went black after a shopping trip got back into the car to go home and the electronic dashboard wouldn't turn on. Called RAC who did a diagnostics test on the car and the technician said the results from his laptop are saying the computer was not able to read the car and its a first because this only happens for cars that are not driveable and cars that are battery dead! Mine was working fine. He tried to do a battery reset still no luck.

Anyways I have called the dealership for a diagnostics appointment hopefully they can fix the issue but reading your experiences doesn't seem like it's a quick fix.

Update today it decided to turn on??? I'm so baffed the last two weeks it wasn't working and today it decided to work?? Really strange. Anyways I'm still taking it into dealership as I feel it may happen again.
This is quite a common fault on the dashboards and a number of forum members have taken their cars to the dealerships for diagnostic and repair, with some returning with the fault not rectified. I've had it a few times, and to be honest, I just live with it as I can't be bothered to be without the car, if I were to let it live at dealer on and off!
If you imagine that after the 2 year car's guarantee, if you need screen replacement, and if the manufacturer won't upgrade with corrections on the screens hardware, I"m afraid many people (including me) will have to spend, occasionally, pointless money for screen replacement. I wish they have made only some defect parts with the specific problems, and the majority is o.k.
 

·
Registered
Joined
·
2 Posts
This is quite a common fault on the dashboards and a number of forum members have taken their cars to the dealerships for diagnostic and repair, with some returning with the fault not rectified. I've had it a few times, and to be honest, I just live with it as I can't be bothered to be without the car, if I were to let it live at dealer on and off!
You should try push for a refund? I know its a hassle but they missold you a product and you're well in your rights to get it.
 

·
Registered
Joined
·
7 Posts
You should try push for a refund? I know its a hassle but they missold you a product and you're well in your rights to get it.
Issue a refund for a brand new car payment, for a defect electronics part? Never heard of it.
In my opinion, (have discussed it with a computer engineer friend who is working for an electronics firm and often visiting factories, checking out the productivity line) since most electronics parts are made in China, there, the manufacturers have a bad policy. When they agree to make a part with specific specs, they can modify the agreement made without the client knows it, saying the result is the same ("good enough" policy). So some parts maybe are not of 100% quality.
It's always my opinion.
 
61 - 80 of 84 Posts
Top