Mercedes A-Class Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
A35 (Edition) done 9,000km without problems.
Recently driver's half of display failed to activate with ignition and stayed black on starting the engine. Central display was normal.
I switched off and on again - same effect: black right side (driver's side) screen, normal central screen, again.
Screen then acted correctly after about 20 minutes switched off (waiting for roadside assistance).

Anyone else had this problem? Thanks!

Peter
 

·
Registered
Joined
·
36 Posts
Absolutely! I think everyone has at some time or another. I've had numerous updates for the display but still occasionally the driver's side goes blank. Usually a switch off, close the doors, shout abuse at the car and threaten to change it for a Toyota Yaris GR. If things are really annoying kick the tyres as well. This does the trick and it always comes back on! Legally you can't drive without a speedo so you should wait till it's working again, unless you have HUD which for me has been a bonus. Don't worry it's just one of those things. Have a good new year.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Absolutely! I think everyone has at some time or another. I've had numerous updates for the display but still occasionally the driver's side goes blank. Usually a switch off, close the doors, shout abuse at the car and threaten to change it for a Toyota Yaris GR. If things are really annoying kick the tyres as well. This does the trick and it always comes back on! Legally you can't drive without a speedo so you should wait till it's working again, unless you have HUD which for me has been a bonus. Don't worry it's just one of those things. Have a good new year.
Thanks, Tukan - sage advice! I'll put it to the test next time. HNY to you too! p
 

·
Registered
Joined
·
8 Posts
Yep, having this issue on my 2019 A200d with the 10inch screens. Always because I’ve left the drivers door open too long and not switched the car on before the welcome screen (Merc logo, mileage, gear position and parking brake) time out and go blank.

I last went to the dealer on the 1st December and they ran an extensive diagnostic on it and the car was logging a signal fault with the screen. They wiped the system and installed a clean latest software update to the car. Was fine up until today when I again left the door open for over minute before starting.

Going to call them tomorrow and see what they say. I’m thinking it’s time for a new screen maybe?
 

·
Registered
CLA 45S
Joined
·
228 Posts
Make sure they have updated all the modules related to the dash, not just MBUX.

The important two are:
A40/16 - Display cluster 'Instrument cluster and head unit'
N133/1 - Instrument cluster

A26/17 MBUX is not as heavily tied to operation of the dash screen.

Get them to check your VIN and confirm the codes of the modules they updated. The names are very similar and can be easily confused otherwise.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Yep, having this issue on my 2019 A200d with the 10inch screens. Always because I’ve left the drivers door open too long and not switched the car on before the welcome screen (Merc logo, mileage, gear position and parking brake) time out and go blank.

I last went to the dealer on the 1st December and they ran an extensive diagnostic on it and the car was logging a signal fault with the screen. They wiped the system and installed a clean latest software update to the car. Was fine up until today when I again left the door open for over minute before starting.

Going to call them tomorrow and see what they say. I’m thinking it’s time for a new screen maybe?
Thanks - I was wondering about the door issue - someone else mentioned it. I'm also suspicious of the new version of the app - it now won't allow me to interact with displays.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Make sure they have updated all the modules related to the dash, not just MBUX.

The important two are:
A40/16 - Display cluster 'Instrument cluster and head unit'
N133/1 - Instrument cluster

A26/17 MBUX is not as heavily tied to operation of the dash screen.

Get them to check your VIN and confirm the codes of the modules they updated. The names are very similar and can be easily confused otherwise.
Thnks - that's useful! I'll heck with my local dealer today.
 
1 - 7 of 7 Posts
Top