Mercedes A-Class Forum banner
1 - 20 of 53 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Picked my A200 AMG Sport up on Wednesday night and already I've got a problem...only 60miles on the clock and the engine diagnosis warning light is on.

Came on during a motorway jouney home from work. Dealer is getting a call first thing tomorrow morning.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
Petrol. Isn't driving noticeably different. They can't see me until Monday so will let you know.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #10 ·
Advice over the phone was to drive it unless something was noticably wrong and call merc assistance if there was.
I had to get to work on Friday (6 mile round trip) and yeah drove it like it was on ice.

Doesn't fill me with confidence. Will see what happens on Monday.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #11 ·
So the car went into MB this morning and they gave me a C class courtesy car free of charge.

I received a phone call at 3pm from the servicing team to inform me that they are unsure what is wrong with the car. They are not familiar with the fault code/don't know how to fix it.

They have had a raise a case with MB to seek further asssistnace. They stated it could up to 72 hours until they hear back from them.

Joy.


Edited by: GNo
 

·
Registered
Joined
·
67 Posts
I'm sorry to hear, still at least they gave you a Merc and not some 107 or Panda whilts it's solved.
The broken Avis-supplied A180 is still parked up withAvis and still has the engine light issue - they haven't worked out how to fix it or what the problem is either.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #16 ·
UPDATE:

MB called today and they have been told by HQ to order a new exhuast gas temp sensor. This should arrive and be fitted tomorrow. HQ said that they will need to analyse some data coming back from the sensor/ecu to be sure that's what was causing the problem.

It sounds like they are just using a knoledge base system to diagnose the problem, so if this doesn't cure it, it'll be onto the next suggestion.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #17 ·
MB fit a new exhaust temp sensor yesterday and the managemnt light went out. They wanted to keep it overnight to perform a cold start/motorway run in the morning.

Just got a call from them there and everything appears okay. Fingers crossed that's it all sorted.

Glad to be getting her back.
 
1 - 20 of 53 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top