Mercedes A-Class Forum banner
1 - 20 of 121 Posts

·
Registered
Joined
·
447 Posts
Discussion Starter · #1 ·
Looking at the Mercedes Me Portal, it appears I have had two OTA updates installed to the infotainment system in the last few weeks - see below. No idea what was updated, I can't see anything different, but since a few days the system appears to have forgotten my home location. I use this a lot on the navigation system, and typically I would say "Hey Mercedes, drive me home", it would give me two options (no idea where it was pulling them from) and it would navigate home. But since a few days it insists no home location has been set, while it certainly has, and it also does the predictive "silent" navigation to the some location.

Anyone else had this issue?
 

Attachments

·
Registered
Joined
·
773 Posts
Could just be fixes as opposed to new features. I have had no problem with the home address (although it does seem to think I live two doors down), but I normally say "Call my wife's mobile" and it calls her, but today it told me that it did not know who it was.

Do you think Mercedes will make an update so I can say "Call the dragons mobile"
 

·
Registered
Joined
·
34 Posts
Cool, never seen the OTA Update working until now!

When was your car build? How did the update Process work? Does your MBUX have the „Progressive“ theme?
 

·
Registered
Joined
·
447 Posts
Discussion Starter · #5 ·
Cool, never seen the OTA Update working until now!

When was your car build? How did the update Process work? Does your MBUX have the „Progressive“ theme?
Neither did I, which is why I was surprised! According to the portal, the car downloaded the update and then a few days later installed it itself. The update mentioned that the installation can take up to 20 minutes, which I am assuming it can only do if the car is switched on. It also mentions it used the car’s own SIM, so I’m not paying for it.

I collected the car in July, not sure when it was built. I can’t see any difference in the MBUX, but as mentioned it could just be patches. It doesn’t have the Progressive theme, or the online music menu (only TuneIn)
 

·
Registered
Joined
·
34 Posts
Neither did I, which is why I was surprised! According to the portal, the car downloaded the update and then a few days later installed it itself. The update mentioned that the installation can take up to 20 minutes, which I am assuming it can only do if the car is switched on. It also mentions it used the car’s own SIM, so I’m not paying for it.

I collected my car in July, not sure when it was built. I can’t see any difference in the MBUX, but as mentioned it could just be patches. It doesn’t have the Progressive theme, or the online music menu (only TuneIn)
Thanks for the clarification.

I collected my A200 in August and it was built in July. I got one Update done "manually" at the dealership and now have the Tidal integration and the new menu look. However I never had a OTA Update, neither MBUX or Maps.

I am still trying to wrap my head around the mystery of MBUX Updates, and have been monitoring forums for some time. On the german a-class forum there is no report of any car ever getting a MBUX OTA update so far, so I was really surprised to see your screenshot! Seems like you are the OTA unicorn. Patient 0. :grin:

Would be interesting to see what was changed, but as it seems in your screenshot there is no changelog with real information.
 

·
Registered
Joined
·
447 Posts
Discussion Starter · #7 ·
Patient 0, I like that ? I have done two map updates, all downloaded on the Me Portal and uploaded to the car via USB stick. Currently on version 250, which appears to be the latest for the UK.
 

·
Registered
Joined
·
168 Posts
A major update requires a reboot of MBUX, which resets all profile information (radio presets, home location etc). This is the same as if you do a reset from the system menu. I don't know if the OTA update warned you to backup your settings. However, if you have backed up your settings then you can restore them - along with your profile.
 

·
Registered
Joined
·
64 Posts
Looking at the Mercedes Me Portal, it appears I have had two OTA updates installed to the infotainment system in the last few weeks - see below. No idea what was updated, I can't see anything different, but since a few days the system appears to have forgotten my home location. I use this a lot on the navigation system, and typically I would say "Hey Mercedes, drive me home", it would give me two options (no idea where it was pulling them from) and it would navigate home. But since a few days it insists no home location has been set, while it certainly has, and it also does the predictive "silent" navigation to the some location.

Anyone else had this issue?
I am also puzzled as to why i get two options for the home address when i say 'Navigate me to home"... Can anyone shed light on this please?
 

·
Registered
Joined
·
168 Posts
I am also puzzled as to why i get two options for the home address when i say 'Navigate me to home"... Can anyone shed light on this please?
One is because your home address is identified in Contacts, the other because your home address is a previous destination.
 

·
Registered
Joined
·
447 Posts
Discussion Starter · #12 ·
A major update requires a reboot of MBUX, which resets all profile information (radio presets, home location etc). This is the same as if you do a reset from the system menu. I don't know if the OTA update warned you to backup your settings. However, if you have backed up your settings then you can restore them - along with your profile.
I haven’t lost any settings, radio presets, etc apart from the home location. Everything is as it was, and I wouldn’t have known there was an update if I hadn’t checked the portal.
 

·
Registered
Joined
·
773 Posts
Some of these updates might be for certain systems because they are different. Firstly you have language, then left or right hand drive, then you have screen size because things lay out different, then whether you have advance navigation and LED lighting, so I don't know if Mercedes had done "one size fits all" and it is able to adapt or they have different versions for different cars.

So with that in mind, I am in the UK with no advance navigation, the exec pack (7 inch drivers, 10.5 inch multimedia) and I have the progressive theme already. I checked today and had this message on Mercedes Me;

"Always in view: the software updates for your vehicle.
We are working continually on extending and improving our vehicle functions and software. Here you will find an overview of the software updates for your vehicle.

No software updates are currently available for your vehicle.

FOSS"
 

·
Registered
Joined
·
34 Posts
So with that in mind, I am in the UK with no advance navigation, the exec pack (7 inch drivers, 10.5 inch multimedia) and I have the progressive theme already. I checked today and had this message on Mercedes Me;
When was your car built?

I think the Progressive Design came with cars being built 2019 or end of 2018 onwards.
 

·
Registered
Joined
·
773 Posts
When was your car built?

I think the Progressive Design came with cars being built 2019 or end of 2018 onwards.
It arrived a few days before I picked it up so it would be a 2019 car. I was lucky the dealership already had the car I wanted on order as stock car, so when I needed the replacement I went for that one. The original one I had was built 2018 but even after 8 "updates" to fix the fault it had no Progressive theme, the last time I saw that car was just before Christmas.

To be honest I don't like it, as the speedo has no dial.
 

·
Registered
Joined
·
215 Posts
This subject makes me particularly annoyed ... why is it that only a few cars (2019) have OTA ... but this has already been widely spoken ...
 

·
Registered
Joined
·
497 Posts
I got a message when I booted the car last night, telling me it was downloading an update to the infotainment. I left it a few minutes, then checked the software update option from the Systems menu and sure enough, the update was there and gave me the option to activate it, which of course required a system restart.


Like the OP, I got a pretty amateurish message purporting to tell me what was contained in the update, but telling me no such thing.


Nothing obvious has changed, though of course it may just be some sort of stabilising patch, which is fine; I just wish they would tell you.


My car was built last July. This is the first OTA update I've had, so maybe newer builds won't need it. But I did read under the map update information in Me, that the automated update option could take up to three months to propagate to all owners. This may have simply been a way of managing expectations, but I've done all my map updates manually, since it is such a simple procedure.
 
1 - 20 of 121 Posts
Top