Mercedes A-Class Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Recently my car has been starting up in petrol mode. It is fully charged each time. Until now (4 months old) it has always started in electric mode as it should. But yesterday and again today the petrol engine started. So I stopped and started the startup sequence several times. Each time I reset the dynamic control to 'electric' a message told me that Electric mode was unavailable... After driving a few hundred yards with the engine I stopped and attempted to get the extremely annoying system to start in electric mode. I managed to make it work, not sure how as I repeated the startup procedure so many times, foot on brake before and after pressing the start button etc. Once it showed EL mode and I thought that it was OK until i touched the accelerator and the mongrel switched instantly to the petrol engine... I had the same issue today and again I managed to get an electric start, again I have no idea what I did to make it work, as I was going through so many combinations of button/brake pressing, along with significant swearing and promising to get rid of the extremely annoying car...

I am expecting this issue to continue and of course there is no 'troubleshooting' section in the poorly presented manual. Poor because along with mistakes like incorrect cruise control functions and assertions that I have features that do not exist, it shows the steering wheel setup for left hand models, but in other areas, deals with controls correctly...
 

·
Registered
Joined
·
10 Posts
I haven't had this exact problem with my A250e but have had two occasions when in electric mode it suddenly and for no obvious reason suddenly changing into petrol mode, in first gear, and full throttle. MB say there is no fault logged. After many weeks of arguing, they have finally agreed to run it for a week to see if it happens to them... I am not sure, but wonder if it is connected to the centre MBUX screen intermittently being black (meaning no modes can be selected and it defaults to "comfort") but also I have had a number of occasions when an error message comes up "Without changing gear, contact workshop". Since it is an automatic, it is impossible to drive without changing gear so that is a stupid message! MB did a software update and recalibrated the gearbox parameters, said that was fixed, then it did it again... I am not happy and have told them that I am reserving the right to reject the car.
Good luck with MB - I am not impressed by their build quality or service
 
1 - 2 of 2 Posts
Top