Mercedes A-Class Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
W177 2018 A200 AMG Line-
Looking to see if anyone has the same issue....
Surround Lighting is set to Active, meaning front & rear lights should light up for 40 secs (only when dark I’m told) when the unlock button is pressed on the key. Every morning when still dark, my headlights don’t light up- but the rear lights do! I’ve tested this out a few times by unlocking and locking the car again several times. Always on the first attempt, nothing from the front headlights but on every other attempt after locking and unlocking, they come on.
 

·
Registered
Joined
·
674 Posts
I might be wrong, but I think the functionality you're referring to keeps the lights on for X secs after you turn off the car and get out. Or perhaps this is something else...
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Yes it does but not just when you get out the car, when you unlock it also before getting in. My issue is my front headlights don’t always come on, but the rear lights do. Do both your front and rear lights come on each time that you unlock? Also, does it matter if it’s day or night?
 

·
Registered
Joined
·
674 Posts
Just tried. It's dark out now and both the rear lights, side puddle lights (under the wing mirrors) and the front day time running lights came on. Not the headlights though...

This was after pressing unlock on the key fob
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Thanks for checking, appreciated. Sorry I shouldn’t have said headlights, I don’t get anything from the front at all the first time I unlock. If I repeat the process, lock then unlock again, I get the same as you.
I’m thinking that I have some kind of software issue. It had an update about 3 weeks ago, so it will be back to the dealer.
Would be good to know what yours does when it’s daylight too.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
Update:
Car been back at dealer. They tried reinstalling the last software update, which resulted in my front lights not working at all. After working through the issue with MB in Germany the dealer was advised to install two replacement headlight control units. This has resolved the issue.
One thing that I didn’t notice/pay attention to before I had this unlocking issue, is that the W177 doesn’t appear to have rear DRLs when engine is running.
 

·
Registered
Joined
·
178 Posts
Sure I see a BMW with rear DRL - could be wrong. Sure I see an article that implied some research has been done and having DRLs on the rear in good conditions could under certain circumstances cause more accidents than it prevents.
 
1 - 9 of 9 Posts
Top