Mercedes A-Class Forum banner
121 - 140 of 140 Posts

·
Registered
W177 2019 A250 AMG-Line Premium Plus
Joined
·
11 Posts
Just a quick update for you all concerning the ongoing saga of the drivers side blank screen, well its been 2 years 7 months and 17 days and my A200 has been to Mercedes dealership on many occasions with the same fault and as I'm posting this update YES my car is in again with the exact same fault. My car went in on the 5th May 2021 and in the late afternoon the service manager phoned me to ask if one of his technicians could take it home so he could monitor the fault, well I said NO politely but I was actually fuming at this request, you do not need to drive the car to establish if the screen is not working, just unlock the door get in the vehicle and if your lucky / unlucky enough you will be looking at a blank screen.
The service manager explained to me that they are only allowed to replace components (ie the screen) only with the authorisation from Mercedes. Well after all this time you can understand I AM NOT HAPPY with Mercedes this is not an uncommon fault and after all this time you would think Mercedes would have some sort of a clue as to what is wrong with this problem and not just updating the software which does not seem to work for the long term. I don't know when I will get the call to collect my car with the so called software update that will cure this problem and the anticipation thereafter of when I get into my vehicle I will be looking at a blank screen again.
I had to threaten to return my 2019 A250 to MB Finance (I have a PCP) before MB finally agreed to replace the entire MBUX digital display unit, and that only after the car had been returned to the dealership 7 times! Problem solved! In the words of the Bard ‘something is rotten in the state of Denmark’! Good luck
 

·
Registered
Joined
·
1 Posts
My 2019 A220 is in the dealers today 17th August - they are sure the drivers 10" screen going blank is a software fault.
It has happened for the second time on the 6th August but the screen returned the following day.
On the 10th May it happened for the first time and the software was updated by the dealer on the 13th May
 

·
Registered
W177 2019 A250 AMG-Line Premium Plus
Joined
·
11 Posts
After my problem was resolved by MB eventually replacing the entire MBUX my a250 AMG Line then experienced battery fault after battery fault. Eventually handed my car back to the dealer, was in positive equity with my PCP arrangement and upgraded to an AMG A35 in June this year. Absolutely love the AMG, no MBUX faults to date although I suspect there is an inherent fault with the MBUX somewhere along the line which MB don’t want to publicise
 

·
Registered
Joined
·
1 Posts
Hey all!

Sorry to bump this thread but I've bought a 2nd hand A180d 68 plate a few days ago. Was sat at a service station with ignition on for 15mins then went to start the car and got the black drivers screen!

I've read through the whole thread and see it needs the screens replaced. My question is am I out of luck because the cars warranty is gone, and they will charge through the nose for diagnostics?

I'm still technically in my 14 days consumer rights if I wanted to return it, but really don't want to since I love the car! And will probably be a hassle if I wanted to.

Thanks all!
 

·
Super Moderator
Joined
·
4,512 Posts
Hey all!

Sorry to bump this thread but I've bought a 2nd hand A180d 68 plate a few days ago. Was sat at a service station with ignition on for 15mins then went to start the car and got the black drivers screen!

I've read through the whole thread and see it needs the screens replaced. My question is am I out of luck because the cars warranty is gone, and they will charge through the nose for diagnostics?

I'm still technically in my 14 days consumer rights if I wanted to return it, but really don't want to since I love the car! And will probably be a hassle if I wanted to.

Thanks all!
Do not accept a defective car.
 

·
Registered
Joined
·
6 Posts
Hi all. Picked up my A35 three weeks ago. New, 71 plate. Love the car. I have one small issue. Twice now in the past ten days, the right side display screen stayed blank on startup. It comes back when I relock, walk out of range and then unlock again. But, a bit of a nuisance, particularly if I’m in a hurry or it’s raining. Looking at this thread, this is not an uncommon issue and I’ve heard that some have just learned to live with it. Others have had software updates and even replacement modules but it still happened afterwards. I reported it to the dealer the first time who just said to “keep an eye on it”…whatever that means!!! I just wondered if any of you have been able to find a fix for this or just learned to live with it.
 

·
Registered
Joined
·
11 Posts
Hi all. Picked up my A35 three weeks ago. New, 71 plate. Love the car. I have one small issue. Twice now in the past ten days, the right side display screen stayed blank on startup. It comes back when I relock, walk out of range and then unlock again. But, a bit of a nuisance, particularly if I’m in a hurry or it’s raining. Looking at this thread, this is not an uncommon issue and I’ve heard that some have just learned to live with it. Others have had software updates and even replacement modules but it still happened afterwards. I reported it to the dealer the first time who just said to “keep an eye on it”…whatever that means!!! I just wondered if any of you have been able to find a fix for this or just learned to live with it.
Exact same issue as my A200d. So far I’m just living with it as I’m sick of taking my car to the dealer for them to just do more updates that don’t fix the problem. On my next service I’m going to push for a new screen and I hope that fixes it once and for all!
 

·
Registered
Joined
·
6 Posts
Exact same issue as my A200d. So far I’m just living with it as I’m sick of taking my car to the dealer for them to just do more updates that don’t fix the problem. On my next service I’m going to push for a new screen and I hope that fixes it once and for all!
As my car is a brand new 71 plate, I would’ve expected the software to be up to date. But, who knows. I’ve contacted them anyway, for the second time now.
 

·
Registered
Joined
·
131 Posts
If it keeps doing it
Hi all. Picked up my A35 three weeks ago. New, 71 plate. Love the car. I have one small issue. Twice now in the past ten days, the right side display screen stayed blank on startup. It comes back when I relock, walk out of range and then unlock again. But, a bit of a nuisance, particularly if I’m in a hurry or it’s raining. Looking at this thread, this is not an uncommon issue and I’ve heard that some have just learned to live with it. Others have had software updates and even replacement modules but it still happened afterwards. I reported it to the dealer the first time who just said to “keep an eye on it”…whatever that means!!! I just wondered if any of you have been able to find a fix for this or just learned to live with it.
From what I've been reading, this is likely bad screen hardware. I don't think anybody got it solved with software updates, though it is the first thing they try. I would insist on new hardware.
 

·
Registered
Joined
·
11 Posts
As I type this now, I am currently sat behind my local dealer with my drivers screen completely blank.
Having just been to the nearby shop, I came back to the car, loaded stuff into the boot and then got in. Started the car and the drivers screen is completely dead.

As I’m at my witts end with this, I carefully drove 30 secs to the dealer and asked for the service team to come and see for themselves. As it’s gone 4pm on a Saturday, they’ve all gone home and no one can help me from the sales team. They told me I call roadside assistance.

So I did just that and the chap on the phone informed me that because I’m at a dealer, they can’t send anyone out to me and that the dealer should sort it. It’s safe to say I was fuming at this point So I’ve driven out onto the road behind the dealer and now someone from roadside assistance is on their way to me.

It’s total madness. A 30k car with a drivers screen that works intermittently. I could just do the get out, lock and try again trick but I shouldn’t have to. I’m going to push for a new screen or something other than an update.

I shall update this thread on Monday when the dealer calls me to explain what they’re doing.
 

·
Registered
Joined
·
6 Posts
As I type this now, I am currently sat behind my local dealer with my drivers screen completely blank.
Having just been to the nearby shop, I came back to the car, loaded stuff into the boot and then got in. Started the car and the drivers screen is completely dead.

As I’m at my witts end with this, I carefully drove 30 secs to the dealer and asked for the service team to come and see for themselves. As it’s gone 4pm on a Saturday, they’ve all gone home and no one can help me from the sales team. They told me I call roadside assistance.

So I did just that and the chap on the phone informed me that because I’m at a dealer, they can’t send anyone out to me and that the dealer should sort it. It’s safe to say I was fuming at this point So I’ve driven out onto the road behind the dealer and now someone from roadside assistance is on their way to me.

It’s total madness. A 30k car with a drivers screen that works intermittently. I could just do the get out, lock and try again trick but I shouldn’t have to. I’m going to push for a new screen or something other than an update.

I shall update this thread on Monday when the dealer calls me to explain what they’re doing.
Bummer. Hope you get it sorted and I look forward to your update on it. I texted the salesman I bought the car from. He’s going to ring me on Monday and get the service centre to book me in. You’re right. Mine is a 40K AMG and it’s unacceptable.
 

·
Registered
Joined
·
11 Posts
Bummer. Hope you get it sorted and I look forward to your update on it. I texted the salesman I bought the car from. He’s going to ring me on Monday and get the service centre to book me in. You’re right. Mine is a 40K AMG and it’s unacceptable.
So I got my car back on Thursday after it spent 5 days with the dealer. I'm told I've had a new screen and the control module that goes with it installed. I just hope this is a permanent fix and I can finally rely on the car now!

I've also just hoovered the car which obviously involves a lot of opening and closing doors without starting the engine, and it's been working perfectly! Whereas before this would usually cause the screen to misbehave.

Have you got much further with yours?
 

·
Registered
Joined
·
12 Posts
So I got my car back on Thursday after it spent 5 days with the dealer. I'm told I've had a new screen and the control module that goes with it installed. I just hope this is a permanent fix and I can finally rely on the car now!

I've also just hoovered the car which obviously involves a lot of opening and closing doors without starting the engine, and it's been working perfectly! Whereas before this would usually cause the screen to misbehave.

Have you got much further with yours?
Hopefully that’ll do it for yours.
They had a look at mine and said it’s a software update first so booked in for that.
 

·
Registered
Joined
·
12 Posts
UPDATE: So, they took it in today for a software update but then contacted me to tell me that a new wiring harness is what is required, so it's on order.
What exactly is a wiring harness and why would it cause the display issue?
 

·
Super Moderator
Joined
·
4,512 Posts
What exactly is a wiring harness and why would it cause the display issue?
Wiring Harness is current terminology for Cable Loom.

Could be many things, cross talk between wires, poor terminations at the connectors, damaged wires etc.

Post #135 details the process for diagnosing/fixing this fault.
 

·
Registered
Joined
·
12 Posts
Wiring Harness is current terminology for Cable Loom.

Could be many things, cross talk between wires, poor terminations at the connectors, damaged wires etc.

Post #135 details the process for diagnosing/fixing this fault.
Yes, it’s a helpful post. Thanks for putting it up. They said three days with them as the dash has to be removed. Sounds like a big deal, compared to how it’s described in that process. Not something I expected after only 6weeks with a brand new car.
 
121 - 140 of 140 Posts
Top