Mercedes A-Class Forum banner
81 - 100 of 140 Posts

·
Registered
Joined
·
11 Posts
Not exactly the same but mine doesn’t always come on. Started happening a few weeks ago. Has always come back on after locking the car and returning so far. Been to dealers but no faults found or updates available, told to return if it goes off altogether :sad::sad:
Hi Ikon,

Did you ever manage to get this permanently fixed? I’m having the same issue with my drivers display. Infotainment display has no issues, but the drivers one seems to not want to work occasionally. I’ve not even had the car a week. My local dealer have installed the latest software update but it’s still happening :(
 

·
Registered
Joined
·
1,108 Posts
Hi Ikon,

Did you ever manage to get this permanently fixed? I’m having the same issue with my drivers display. Infotainment display has no issues, but the drivers one seems to not want to work occasionally. I’ve not even had the car a week. My local dealer have installed the latest software update but it’s still happening :(
Hi

It seems to have fixed itself, not had the issue for ages now (touch wood!!!!)
 

·
Registered
Joined
·
11 Posts
Hi

It seems to have fixed itself, not had the issue for ages now (touch wood!!!!)
Good to hear! I’m 90% sure mine had something to do with not starting the engine for so long after initially getting into the car.

I first noticed this when I went to my car and realised I’d left something in the house. I left the drivers door open and went back inside for what I’d foregotten. Hadn’t started the car, literally just opened the door and was welcomed by both the screens.

When I returned to set off, that’s when the screen didn’t come on after I started the engine. No matter what I press, there’s no response.

If I get in the car and start straight away, we’re fine, and there’s no issues when driving either.

It’s as if the screen isn’t detecting that the car has been started again, like it’s timing out after so long to preserve battery power. Leaving the car locked for a few mins works every time. I guess that’s all it takes for a full shutdown of the system.

Not sure what to do really.
 

·
Registered
Joined
·
11 Posts
Just to add-

I’ve been sat in the car for around 20 mins trying to work out how the issue arises. I’ve been listening to music and the drivers screen is again unresponsive. The left side steering wheel controls have also stopped working, so I cannot control MBUX through the wheel. Touchpad and screen still working though.
 

·
Registered
Joined
·
8 Posts
I have a A180d Sedan V177 purchased new Nov.2019 and today when unlocked the car both of the 10' displays were blank. Got out of it and tried to lock it but it wouldn't respond to the remote. Got inside again, switched the engine on for a whil, then off. Got out of it and locked as it should. The car is kept in a garage in normal temperature conditions. I have driven some kilometres, everything works except the dual 10' screens (climate, radio etc). I have reported the problem to the dealership and booked for a check on Monday. They told is either an update that needs to be done or a display control unit needs to be replaced. Will be back with news next week.

UPDATE 6/16/2020: They told me the screens need to be replaced, waiting to receive and replace them.
UPDATE 6/24/2020: Dealer haven't yet received the new screens part, still waiting...
UPDATE 7/04/2020: Still waiting for them to receive the new 10" screens. I wondered why it is taking too long for a part in the EU to arrive with such delay...
UPDATE 7/13/2020: The screens part arrived finally, the dealer's service have replaced the defect screens and everything is working as expected. Hope this was my first and last trouble.
 

·
Registered
Joined
·
2 Posts
My 2019 A220 is now doing this. The screen with the speedometer is black but the other one is working fine. Another thing I noticed was when I use my turn signals I don’t get the clicking noise. I was hoping I could let it sit and then it would come back on but no luck. Taking it to the dealership in a few days to get it looked at.
 

·
Registered
Joined
·
2 Posts
Hi guys I'm from the UK and my new 2019 A220 AMG Line Premium Plus is having the same issue. Screens went black after a shopping trip got back into the car to go home and the electronic dashboard wouldn't turn on. Called RAC who did a diagnostics test on the car and the technician said the results from his laptop are saying the computer was not able to read the car and its a first because this only happens for cars that are not driveable and cars that are battery dead! Mine was working fine. He tried to do a battery reset still no luck.

Anyways I have called the dealership for a diagnostics appointment hopefully they can fix the issue but reading your experiences doesn't seem like it's a quick fix.

Update today it decided to turn on??? I'm so baffed the last two weeks it wasn't working and today it decided to work?? Really strange. Anyways I'm still taking it into dealership as I feel it may happen again.
 

·
Registered
Joined
·
130 Posts
This is quite a common fault on the dashboards and a number of forum members have taken their cars to the dealerships for diagnostic and repair, with some returning with the fault not rectified. I've had it a few times, and to be honest, I just live with it as I can't be bothered to be without the car, if I were to let it live at dealer on and off!
 

·
Registered
Joined
·
8 Posts
Hi guys I'm from the UK and my new 2019 A220 AMG Line Premium Plus is having the same issue. Screens went black after a shopping trip got back into the car to go home and the electronic dashboard wouldn't turn on. Called RAC who did a diagnostics test on the car and the technician said the results from his laptop are saying the computer was not able to read the car and its a first because this only happens for cars that are not driveable and cars that are battery dead! Mine was working fine. He tried to do a battery reset still no luck.

Anyways I have called the dealership for a diagnostics appointment hopefully they can fix the issue but reading your experiences doesn't seem like it's a quick fix.

Update today it decided to turn on??? I'm so baffed the last two weeks it wasn't working and today it decided to work?? Really strange. Anyways I'm still taking it into dealership as I feel it may happen again.
This is quite a common fault on the dashboards and a number of forum members have taken their cars to the dealerships for diagnostic and repair, with some returning with the fault not rectified. I've had it a few times, and to be honest, I just live with it as I can't be bothered to be without the car, if I were to let it live at dealer on and off!
If you imagine that after the 2 year car's guarantee, if you need screen replacement, and if the manufacturer won't upgrade with corrections on the screens hardware, I"m afraid many people (including me) will have to spend, occasionally, pointless money for screen replacement. I wish they have made only some defect parts with the specific problems, and the majority is o.k.
 

·
Registered
Joined
·
2 Posts
This is quite a common fault on the dashboards and a number of forum members have taken their cars to the dealerships for diagnostic and repair, with some returning with the fault not rectified. I've had it a few times, and to be honest, I just live with it as I can't be bothered to be without the car, if I were to let it live at dealer on and off!
You should try push for a refund? I know its a hassle but they missold you a product and you're well in your rights to get it.
 

·
Registered
Joined
·
8 Posts
You should try push for a refund? I know its a hassle but they missold you a product and you're well in your rights to get it.
Issue a refund for a brand new car payment, for a defect electronics part? Never heard of it.
In my opinion, (have discussed it with a computer engineer friend who is working for an electronics firm and often visiting factories, checking out the productivity line) since most electronics parts are made in China, there, the manufacturers have a bad policy. When they agree to make a part with specific specs, they can modify the agreement made without the client knows it, saying the result is the same ("good enough" policy). So some parts maybe are not of 100% quality.
It's always my opinion.
 

·
Registered
Joined
·
4 Posts
My 2019 A220 is now doing this. The screen with the speedometer is black but the other one is working fine. Another thing I noticed was when I use my turn signals I don’t get the clicking noise. I was hoping I could let it sit and then it would come back on but no luck. Taking it to the dealership in a few days to get it looked at.
Did they manage to fix it? My 2020 A180D Premium Plus has had a blank drivers screen twice, it came back both times.
 

·
Registered
Joined
·
1 Posts
I’ve only had my A class A200 since March this year. 20 plate. The display screen went black whilst I was driving and hasn’t come back. mercedes have been out today and apparently it’s a known problem. It’s been taken to our local dealer to resolve. Meanwhile I await a hire vehicle.
 

·
Registered
Joined
·
2 Posts
No. The dealership I took it to royally screwed up. The service guy I talked to no longer works there because he was terrible at his job. He updated nothing about what was going on. They never ordered any parts for it. I'm now having to take it somewhere else over a hour away and they can't get me in for 2 weeks.
 

·
Registered
Joined
·
8 Posts
You can always complain to the central dealership of your state, concerning the bad service you received. I believe that they'll guide you to the best option. Letting them know your trouble, I believe it will work in your favor.
 

·
Registered
W177 2019 A250 AMG-Line Premium Plus
Joined
·
11 Posts
Hi hoping someone can help as don't want another car destroyed by the dealer lol
The main driver screen 10.25 just goes off for no reason or warning wondered if any one else had the problem as only had the car 3 weeks and apart from this its faultless
Thanks
The same has been happening with my A250 AMG-Line (68 plate W177) from day 1. Despite software update after software update and two replacement control units, the issue hasn’t been resolved. Back to the dealer three times in December 2020 with yet another replacement control unit installed on New Years Eve- failed again tonight! I resolve by switching off the engine, exiting and dead locking the car, leaving it for five minutes and then unlock the car again- Hey Presto it works but only until the next time the instrument cluster fails again!
 
81 - 100 of 140 Posts
Top